Apple Patches Untethered Jailbreak Exploit Corona Uses In iOS 5.1 Beta 3

by Ahmed Omar on January 13, 2012

That cat and mouse game between iPhone hackers and Apple employees is getting a real war more than a game. After several months of hard work, the iPhone hacker pod2g with the help of the iPhone Dev Team and Chronic Dev Team could release iOS 5.0.1 untethered jailbreak for all A4 devices. Although iPhone 4S and iPad 2 are not jailbroken yet, pod2g said that the A5 untethered is matter of days away.

 Corona 5.0.1

For those of you who haven’t updated to iOS 5.0.1 yet, it’s time to do so.

Couple of days ago, Apple released iOS 5.1 beta 3 to developers. iOS 5.1 beta 3 revealed some new features and bug fixes. With the release of iOS 5.1 beta 3, it was unveiled that Siri is most probably coming to the iPad 3 and may be all iOS devices. iOS 5.1 beta 3 also brought back the 3G toggle on iPhone 4S.

However, iOS 5.1 beta 3 brings some bad news to the jailbreak community. According to iPhone developer Nadeem Ateyeh on Twitter (via @veeence), iOS 5.1 beta fixes the Corona iOS 5.1 untethered. According to the developer, iOS 5.1 is not susceptible to the Corona jailbreak since it fixes the bugs Corona uses to untether iOS 5.0.1.

Of course, everyone of you must update to iOS 5.0.1 right now or at least save iOS 5.0.1 SHSH blobs using latest TinyUmbrella release.

Once updated to iOS 5.0.1, you can follow our guide posted here to jailbreak iOS 5.0.1 untethered on iPhone 4, 3GS, iPad 1, iPod touch 4G, 3G.

And as usual, don’t forget to subscribe to our newsletter, follow me on Google+ and Twitter for up-to-date news.

If you found this post useful, hopefully hit the +1 (recommend) button ⇉


Add CydiaHelp on Google

You can follow on Twitter, join our Facebook fanpage and add me on Google+ to keep yourself updated on the latest jailbreak and unlock news.
  • http://twitter.com/Rezildans Das Volkan

    I have an iPad 2 3G with untethered jailbreak (iOS 4.3.3). Do I have to update or stay calm? On Cydia on top left screen, it says “SHSH : iOS 4.3.5, 5.0.1″…

  • Nathanaashaw

    If you do not upgrade before next update is released by Apple, you may be forced to upgrade to newest version that cannot be jailbroken. That is my impression at least. I’d say upgrade now to be safe, and go without a jailbreak for a few days before A5 jailbreak is released.

  • Austin_sch

    I Would just download the 5.0.1 software, and hold off on updating. you can keep the software on your desktop and when the jailbreak comes out then you can update. Thats what I would do.

  • karim

    yes . Update

  • Mad Mac

    When Apple closes the ticket, you most likely will be unable to update to 5.0.1. So far, you cannot even update to 5 even if your shsh is saved. Most likely you cannot update to 5.0.1 too.

  • http://twitter.com/Rezildans Das Volkan

    Yup, I already downloaded the iPad 2 3G ipsw file just in case (iPad2,2_5.0.1_9A405_Restore.ipsw). But what frustrates me is written on Cydia’s FAQ section – Upgrading/Downgrading:

    Q: How do I use SHSH to downgrade/upgrade to a version?

    A: You can use a free tool called TinyUmbrella to make it easier to fake the necessary firmware signature process (“TSS server”) — using your saved SHSH — while restoring your device to your desired firmware version (IPSW file) using iTunes.

    This is a procedure reserved for the bold and adventurous, with many possible error messages along the way (although they can generally be solved with some research).

    (On iPad 2 GSM/CDMA, this method for downgrading no longer works.)

    Note: iOS 5 has a new SHSH mechanism (with APTicket). You can use SHSH to downgrade from iOS 5.x to 4.x using normal methods, but using SHSH for iOS 5.x is more complex; you can try using redsn0w to stitch blobs to a custom firmware file and use that file to restore.)”

  • Kay

    Nooooo! Even with the software, you’re going to need the blobs shsh for your phone. Even with the ipsw’s, when you go to restore or do a custom restore it’s gonna check apple’s server to verify. That’s a HUGE part of all this jailbreaking/unlocking drama. WITHOUT verification from apple (or if apple stops signing the firmware) your only resource is SHSH blobs!

  • Chachi_star

    Good. That’s what A4 device users get for being impatient on an untethered jailbreak when they could have easily waited for the A5 jailbreak considering they already had two out. Lucky for us A5 users the exploit isn’t the same as A4 so hopefully it won’t be patched :)

  • Kay

    Soo… save your shsh blob with TinyUmbrella. Update BUT PRESERVE YOUR BASEBAND! by doing a custom firmware update. And save that shsh blob. All else fails, you will be able to downgrade again and still have your shsh saved.

    Not sure about ipad’s but I find it easier to downgrade with TinyUmbrella, do a new Jailbreak with Redsnow, then restore from backup to get all my stuff (contacts…) back.

  • Chachi_star

    I’d update now. I’m not sure if downgrading is possible. I just did my ipad2 and 4S the other day

  • http://twitter.com/Rezildans Das Volkan

    No, no. If you read my first post, it says that Cydia has already got the SHSH blob of my iPad 2 for 4.3.5 & 5.0.1. But as I tried to explain, on Cydia again, it says that Apple has changed the signing SHSH process to another troubled way so that saving SHSH through Cydia (Cydia automatically saves SHSHs if you already JB’d your iDevice, as it did in my case) or Tiny Umbrella may not work in upgrading to iOS 5.xx.

    That’s the whole point of my worries.

  • Chachi_star

    I don’t mean to troll on here but sorry I just think it was ridiculous of A4 users to push the poor dev team to release the untether when they already had two perfectly good jailbreaks already. It wouldn’t have killed to wait a bit.

  • Cobaltthegreat

    A5 users, update to 5.0.1 asap. Once apple drops the new firmware it could be a long wait until you get another shot at this.

  • http://pulse.yahoo.com/_5FLRQI2X2LU3IHMCG7HEAEFD5I Cat Astrophy

    Um better get iPad2 and 4S done before 5.1 pod2g or your time was wasted

  • Minas

    why should his time be wasted? all current a5 users are on 5.0.1 (hopefully) and that should stay so until the jailbreak is out. even if 5.1 comes out

  • http://pulse.yahoo.com/_5FLRQI2X2LU3IHMCG7HEAEFD5I Cat Astrophy

    Because not nearly as many people will read a topic like this. A REAL headliner would be a JB for the latest devices…so lots of people will only just then be getting the message to have 5.0.1…and if pod2g is too slow…it may already be too late

  • Landsharker

    Wtf is taking so long for the jailbreak for iPad 2

  • Smeghead

    Landsharker, If you have aproblem with it why don’t you do it? Or just shut your mouth n wait you spoilt little brat.

  • z00

    can someone explain why (or cite a reference source) it won’t be possible to upgrade to 5.0.1 if SHSHs are saved using Cydia/Tiny Umbrella ?

  • Josh

    Ya I wanna jail break my iPad 2 can”t wait

  • ..

    @ Landsharker :
    Never mind the last comment folk’s..
    Just another spoiled little ungrateful brat.

  • Bcrossb

    can i save my shsh using redsn0n or pawnage for my iPhone 4s on 5.0.1??

  • Jasin_227

    I have an iPhone 4s on version 5.0. Do I HAVE to upgrade to 5.0.1? If so, why? I’m very confused. Thanks

  • http://www.facebook.com/profile.php?id=100000004825217 Johnny Lee Stewart

    You don’t have to if you do not want the jailbreak but the reason you need to is that 5.0 is not going to be jailbroken EVER!!! The jailbreak their working on is only to be used with 5.0.1 because their two different softwares DUH!!!

  • http://www.facebook.com/profile.php?id=100000004825217 Johnny Lee Stewart

    no has to be tiny umbrella listen

  • http://www.facebook.com/profile.php?id=100000004825217 Johnny Lee Stewart

    i have an a4 device and i do not think its fair that we got it and i could’ve waited but now I’m waiting on the a5 release so i can go get me an ipad2 otherwise the 1st iPad is going to be my option because i can not deal with a no jailbreak problem so il find a solution.

  • http://www.facebook.com/profile.php?id=100000004825217 Johnny Lee Stewart

    You need help with the jailbreak let me know, i program in my free time

  • http://www.facebook.com/profile.php?id=100000004825217 Johnny Lee Stewart

    update it right now and save your shsh for 5.0.1 right after, and then you can downgrade back to 4.3.3 IF you have the shah blobs but if you don’t your SOL

  • http://www.facebook.com/profile.php?id=100000004825217 Johnny Lee Stewart

    they never figured out how to save the 5.0 blobs stupid

  • http://www.facebook.com/profile.php?id=100000004825217 Johnny Lee Stewart

    Ignore em, they never made it possible to save the 5.0 blobs so they thought they were saved but really were not, so you aint got nothin to worry bout

  • Cesar Rubio

    I know this could be a dumb question, but this means that Apple patched the entire untethered jailbreak or just the Corona method?, or by patching one the other is automatically patched?, thanks in advance

  • Iks47

    hi, I am having trouble installing corona 5.0.1 saying it cannot comply. I am using an ipod 3g on 5.1 update how do i get corona to work?

  • Larrydunzo

    Doesn’t work on 5.1 that’s what he said in the article

Previous post:

Next post: